[Bucardo-general] Some more questions

Hadri Rahman hadri90 at gmail.com
Mon Nov 10 03:03:07 UTC 2014

Okay, so I've tried to change the permission for .pgass in user "root" but
I got the error message: chmod: cannot access `~./pgpass': No such file or

So I then reverted back to my own account, changed the file permission, but
when I tried to install Bucardo I got the error message:

"INSTALLATION FAILED! Looks like you already have Bucardo installed there.
Try running "Bucardo upgrade"

The contents of the .pgpass file so far looks like this:


On Sun, Nov 9, 2014 at 5:04 AM, Joshua Tolley <josh at endpoint.com> wrote:

> On Fri, Nov 07, 2014 at 03:42:59PM -0500, Greg Sabino Mullane wrote:
> > On Fri, Nov 07, 2014 at 10:54:54AM +0800, Hadri Rahman wrote:
> > > A psql connection (via user postgres) seems to work:
> > >
> > > postgres at vmachine:$ psql -h localhost -p -5432 -U bucardo bucardo
> > > Password for user bucardo:
> >
> > Why is it asking for a password here? Are you typing anything in?
> > If the .pgpass file is being read and working, this prompt should
> > not be appearing.
> Are the permissions on .pgpass correct? From
> http://www.postgresql.org/docs/9.3/static/libpq-pgpass.html:
> "On Unix systems, the permissions on .pgpass must disallow any access to
> world
> or group; achieve this by the command chmod 0600 ~/.pgpass. If the
> permissions
> are less strict than this, the file will be ignored."
> --
> Josh Tolley   josh at endpoint.com   801-987-0252
> End Point Corporation  http://www.endpoint.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20141110/e68353a1/attachment.html>

More information about the Bucardo-general mailing list