[Bucardo-general] Getting "swap" sync setup

Don Drake dondrake at gmail.com
Thu Mar 4 20:41:00 UTC 2010

I tried to get replication going on a test database and ran into some

What I tried to do was first replicate all the data to the second db by
using the push delta type while using onetimecopy=2.

That seemed to work, but then I tried to use swap, so I removed the
pushdelta sync and then tried to add a new one with the existing herd, but I
got an error about standard_conflict not being set.  I even tried to add a
new herd (using all tables) while setting standard_conflict, but when
inspecting the goat table, the column was never set.  The only way I could
get it to work was to use an update command.

The next problem was with the sequences, I used a standard_conflict of
'highest' in my update goat statement, but they were not getting
replicated.  I was getting this error in the bucardo log:
Kid exiting at cleanup_kid. Reason: Unknown conflict type for sequence:

I took a quick look at the code in Bucardo.pm and that exists on line 5082.
Take a look at the if statement above it:
elsif ('lowest' eq $sc and 'highest' eq $sc) {

How could that ever be true?  I switched it to an "or" and still wouldn't
replicate.  I removed all sequences from the goat table and things started
working again.

Did I miss any steps?

Is there a way to update the standard_conflict using bucardo_ctl?



Donald Drake
Drake Consulting
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20100304/6420dc48/attachment.html 

More information about the Bucardo-general mailing list