[Bucardo-general] can not start new sync while bucardo is running?

Alexey Klyukin porkbird at me.com
Wed Aug 1 13:47:53 UTC 2012


On Aug 1, 2012, at 7:38 AM, Yan Chunlu <springrider at gmail.com> wrote:

> I am using version 4.5.0, and have made a sync up and running.  and I am planning to add a new slave sync,  the list syncs shows as below:
> bucardo_ctl - list syncs
> Sync: madisonsync  (pushdelta)  maintables =>  madisondiggcontent   (Active)
> Sync: mainsync     (pushdelta)  maintables =>  vanburendiggcontent  (Active)
> "mainsync" is up and running correctly, while madisonsync does not.
> I tried bucardo_ctl kick madisonsync and it returns immediately but nothing happen.
>  "kick madisonsync 0" will never return.
> I have also tried "bucardo_ctl  reload madisonsync" it also does not return, just hanging there.
> "bucardo_ctl  activate madisonsync" will return immediately but nothing happen.
> during those operations nothing related with madisonsync in log.bucardo. 
> do I have to bucardo stop and bucardo start to make the new sync running?
> below is the status of bucardo:
> Days back: 3  User: bucardo  Database: bucardo  Port: 5432  PID of Bucardo MCP: 1402
> Name        Type  State    PID  Last_good Time  I/U/D     Last_bad Time
> ===========+=====+========+====+=========+=====+=========+========+====
> madisonsync| P   |idle    |    |unknown  |     |         |unknown |    
> mainsync   | P   |WAIT:20s|1407|20s      |31s  |255/0/192|unknown |   

Have you tried running bucardo_ctl validate madisonsync? Any problems reported along the way?


More information about the Bucardo-general mailing list