[Bucardo-general] Version collision confusion

David E. Wheeler david at justatheory.com
Wed Nov 28 00:14:30 UTC 2012

On Nov 23, 2012, at 6:09 AM, Martin Bramwell <martinhbramwell at yahoo.com> wrote:

> Hi, 
> I'm writing to get clarification about versions and also a bit to point out that Bucardo's  getting started material is less than friendly to someone like me.  I have small experience* with PostgreSql; none at all with Perl or Bucardo.
> I used the documentation at   http://bucardo.org/wiki/Bucardo/Installation 
> 	• Requirements:   What are these things below?  Where can I find them?  How can I tell if I need to find them? Is there an "all_clear_for_Bucardo" environment validation script of some kind?

Well, first of all, install an RPM or other type of package if you can.

If you can't, run this command:

    perl Makefile.PL

It will show you if anything is missing, e.g.:

    Warning: prerequisite DBD::Pg 2.0 not found.

Use your packaging system to install dependencies if you can (usually called perl-Something, in this case perl-DBD-Pg), or else use the CPAN client:

    cpan DBD::Pg
> 	• apt-get install postgresql-plperl-9.0 :  This got me the error message ... 
>       "postgresql-plperl-9.0 : Depends: libperl5.10 (>= 5.10.1) but it is not installable"
> ... trying to deal with that with : apt-get install libperl5.10  got me this ...
>  "No candidate version found for libperl5.10"

Sounds like your distribution's PostgreSQL 9.0 package is horked.

> I got lucky guessing that   apt-get install postgresql-plperl-9.1   would be the solution.
> Please tell me -- ¿¿ can I safely use postgresql-plperl-9.1 ??

Yes, PostgreSQL 9.1 has been released and stable for several months.

> Also, shouldn't  postgresql-plperl   be in the requirements list above?

We probably ought to mention that the PostgreSQL build requires PL/Perl.

> Please accept that my criticisms are intended to be constructive.



More information about the Bucardo-general mailing list