[Bucardo-general] Version collision confusion
martinhbramwell at yahoo.com
Fri Nov 23 14:09:09 UTC 2012
I'm writing to get clarification about versions and also a bit to point out that Bucardo's getting started material is less than friendly to someone like me. I have small experience* with PostgreSql; none at all with Perl or Bucardo.
I used the documentation at http://bucardo.org/wiki/Bucardo/Installation
1. Requirements: What are these things below? Where can I find them? How can I tell if I need to find them? Is there an "all_clear_for_Bucardo" environment validation script of some kind?
* boolean (Bucardo 5.0 and higher)
2. apt-get install postgresql-plperl-9.0 : This got me the error message ...
"postgresql-plperl-9.0 : Depends: libperl5.10 (>= 5.10.1) but it is not installable"
... trying to deal with that with : apt-get install libperl5.10 got me this ...
"No candidate version found for libperl5.10"
I got lucky guessing that apt-get install postgresql-plperl-9.1 would be the solution.
Please tell me -- ¿¿ can I safely use postgresql-plperl-9.1 ??
Also, shouldn't postgresql-plperl be in the requirements list above?
Please accept that my criticisms are intended to be constructive.
* My first experience with computers was punch cards and Fortran and I've been at ever since. So I'm not a nube in that sense :-)
** Welcome to the 3rd world.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Bucardo-general