[Bucardo-general] Problems with Bucardo 5.0 installation in UBuntu 13.10

Selva manickaraja mavles78 at gmail.com
Mon Jul 14 15:18:31 UTC 2014

Hi All,

I have attempted to install Bucardo 5.0 as per instruction INSTALL file.
Finally as recommended, I ran the "make test" command. It failed here with
long list of message. Though I cannot understand all but the 3rd last line
says "Result: FAIL". I am attaching the file with this email.

Though the system reported error with "make test", I went ahead with "sudo
make install". Quite strangely it worked so went on to "bucardo install". I
updated the PIC directory to "/var/lib/bucardo" as it complaint the path
proposed by it initially was not available in my system. The installation
completed successfully I suppose as the database pointed to in the
"/etc/bucardorc" file was able to create the bucardo database and user. We
are running 9.0 with streaming replication and log-shipping as a
multi-cluster setup . No we want to proof to our management that pg is
capable of multi-master to load balance the huge transactions.

So in my test machine I have pg running on port

5432 - as bucardo database
5433 - as master1
5435 - as master2.

Following commands used to add db and sync.
adding db - "bucardo add db master1 dbname=np host=localhost port=5433
user=postgres pass=postgres,master2 dbname=np host=localhost port=5435
user=postgres pass=postgres"

adding sync - "bucardo add sync np_mm_repl
dbs=master1:source,master2:source tables=all"

The commands successfully created the dbs and syncs. So when I typed
bucardo status , the sync get displayed (screen attached). But when I psql
to master1 and master2 to insert and delete records to "tbl_1". But the
data does not seem to be replicated between these 2 tables from these 2
databases. Looks like replication is not working though bucardo seem to be
running well.

Can someone please help me out to shed some light on what is not right here?

Highly appreciate your help.
Regard - Selvam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20140714/1f5e64be/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bucardo_status.png
Type: image/png
Size: 60999 bytes
Desc: not available
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20140714/1f5e64be/attachment-0001.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bucardo_test_results
Type: application/octet-stream
Size: 15650 bytes
Desc: not available
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20140714/1f5e64be/attachment-0001.obj>

More information about the Bucardo-general mailing list