[Bucardo-general] Problems installing Bucardo 5.0 in UBuntu 13.10

Selva manickaraja mavles78 at gmail.com
Mon Jul 14 14:56:03 UTC 2014

Hi All,

I have attempted in many ways, but was not able to successfully install
Bucardo 5.0 in UBuntu 13.10

Below is what I did and what was the system response.

*Step 1 (DBIx::Safe installation)*

1.sudo apt-get install libdbix-safe-perl. The installation was successful.

*Step 2 (Bucardo 5.0 installation)*

Remark : The step in the wiki is for Bucardo 4.4.8.tar.gz. So I followed
the instructions in README and INSTALL files.

1. I "untar" Bucardo by typing  tar xvfz "Bucardo-5.0.0.tar.gz"
2. cd Bucardo-5.0.0
3. I typed "perl Makefile.PL". My system responded as below:
    Writing Makefile for Bucardo
    Writing MYMETA.yml
3. Following that I typed perl "make". My system responded as below:
    Skip blib/lib/Bucardo.pm (unchanged)
    cp bucardo blib/script/bucardo
    /usr/bin/perl -MExtUtils::MY -e 'MY->fixin(shift)' --
    Manifying blib/man1/bucardo.1pm
    Manifying blib/man3/Bucardo.3pm
4. As recommended I ran the "make test" command. It failed here with long
list of message. Though I cannot understand
    all but the 3rd last line says "Result: FAIL". I am attaching the file
with this email.

Though the system reported error with "make test", I went ahead with "sudo
make install". Quite strangely it worked so went on to "bucardo install". I
updated the PIC directory to "/var/lib/bucardo" as it complaint the path
proposed by it initially was not available in my system. The installation
completed successfully I suppose as the database pointed to in the
"/etc/bucardorc" file was able to create the bucardo database and user. So
I made use of the instruction found in the blog at "
for creating the db and the sync. My architecture is a multi-cluster setup.
This is because we are running 9.0 with streaming replication and
log-shipping. So we want to proof to our management that pg is capable of
multi-master to load balance the huge transactions.

So in my localhost I have pg running on port

5432 - as bucardo database

5433 - as master1

5435 - as master2.

So we use the following commands to add db and sync.

adding db - "bucardo add db master1 dbname=np host=localhost port=5433
user=postgres pass=postgres,master2 dbname=np host=localhost port=5435
user=postgres pass=postgres"

adding sync - "bucardo add sync np_mm_repl
dbs=master1:source,master2:source tables=all"

The commands successfully created the dbs and syncs. So when I typed
bucardo status , the sync get displayed. The screen is attached with this
email. But when I psql to master1 and master2 to insert and delete records
to "tbl_1". But the data does not seem to be replicated between these 2
tables from these 2 databases. Looks like replication is not working though
bucardo seem to be running well. That's what I feel.

Can someone please help me out to shed some light on what is not right here?

Highly appreciate your help.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20140714/ae585412/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bucardo_test_results
Type: application/octet-stream
Size: 15650 bytes
Desc: not available
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20140714/ae585412/attachment-0001.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bucardo_status.png
Type: image/png
Size: 60999 bytes
Desc: not available
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20140714/ae585412/attachment-0001.png>

More information about the Bucardo-general mailing list