[Bucardo-general] Some more questions

Hadri Rahman hadri90 at gmail.com
Thu Nov 6 04:23:15 UTC 2014

Sorry for the extra message, I sent out the previous message by accident.
Anyway, the contents of pg_hba.conf are:

Database administrative login

local all postgres peer

"local" is for Unix domain socket connections only:
local all all peer

host all all md5

host all all ::1/128 md5

Applow replication connections from localhost:

host replication rep md5
local bucardo bucardo                       md5

On Thu, Nov 6, 2014 at 12:18 PM, Hadri Rahman <hadri90 at gmail.com> wrote:

> So just to be on the safe side, I've changed the password for user
> "bucardo" in psql to a different password, and changed the value in the
> .pgpass file as well.
> So when I tried to install it again, I got the error message:
> DBI connect('dbname=bucardo;host=localhost;port=5432','bucardo',...)
> failed: fe_sendauth: no password supplied at /usr/local/bin/bucardo line
> 8627.
> and when I tried running the installer again, I would get the error
> message:
> "INSTALLATION FAILED! Looks like you already have Bucardo installed there.
> Try running "Bucardo upgrade" instead. I've also tried changing the
> password back but i'm still having this issue. The contents of my
> pg_hba.conf are:
> Database administrative login:
> local
> On Sat, Nov 1, 2014 at 12:27 AM, Greg Sabino Mullane <greg at endpoint.com>
> wrote:
>> On Tue, Oct 28, 2014 at 11:35:11AM +0800, Hadri Rahman wrote:
>> > Okay, so I did as you instructed, but after it said "Database creation
>> is
>> > complete" there's an error message saying "DBI
>> > connect('dbname=bucado;host=localhost;port=5432', 'bucardo',...) failed:
>> > fe_sendauth: no password supplied at /usr/local/bin/bucardo line 8639"
>> >
>> > I've already created user "Bucardo" in postgres with the command: CREATE
>> > USER bucardo SUPERUSER password 'secret_password'; so I'm not sure how
>> I'm
>> > getting this error message.
>> No password supplied would indicate that neither --dbpass nor ~/.pgpass
>> nor the bucardo.db table has a password. There is some sort of bug
>> regarding
>> empty passwords but I have never been able to duplicate it. If anyone is
>> experiencing such problems, please come to #bucardo on irc.freenode.net
>> so we can try to figure it out.
>> --
>> Greg Sabino Mullane greg at endpoint.com
>> End Point Corporation
>> PGP Key: 0x14964AC8
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20141106/6c174f54/attachment.html>

More information about the Bucardo-general mailing list