[Bucardo-general] (no subject)

Hadri Rahman hadri90 at gmail.com
Mon Nov 17 08:08:19 UTC 2014

So I've installed Bucardo onto my system, but whenever I try to perform a
sync or running it in general, I would get the error message:

DBI connect('dbname=bucardo;host=localhost;port5432', 'bucardo',...)
failed: FATAL: password authentication failed for user "bucardo"
FATAL: password authentication failed for user "bucardo" at
/usr/local/bin/bucardo line 296

I've checked and confirmed that the user "Bucardo" is in the PostgreSQL
database, and that the passwords in both the database and .pgpass are
correct. I've searched online and it was suggested that there might be a
problem in my pg_hba.conf file. The contents of the file are as follows:

#Database administrative login by Unix domain socket
local     all        postgres         peer
#"local" is for Unix domain socket connections only
local     all        all              peer
local     all        all         md5
local     all        all     ::1/128         peer
#Allow replication connections from localhost:
host     replication rep     md5
local    bucardo     bucardo                      md5

I've tried changing the authentication method for user "bucardo" from md5
to trust and ident, but I'm still getting the same error. Any help and
suggestion would be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20141117/c30c8a0e/attachment.html>

More information about the Bucardo-general mailing list