[Bucardo-general] Setting up Bucardo with Postgres 9.5 Issues

Logan, Sean slogan01 at harris.com
Wed Jun 14 21:45:37 UTC 2017

Hi all,

I am trying to set up Bucardo replication with our postgresql 9.5 cluster and I have not been able to get it working.  I have installed the latest version (and tried several version below it 5.4.1 downwards) with zero success.

I have managed to set up Bucardo and have it connect to the postgres instance.  I can add a database, but the problem begins happening when I attempt to add tables to the syncing.

./bucardo add db dbname db=dbname command succeeds

Upon running the ./bucardo add all tables command I get the following output:

DBD::Pg::st execute failed: ERROR:  DBI connect('dbname=dbname,'bucardo',...) failed: fe_sendauth: no password supplied at line 62.
CONTEXT:  PL/Perl function "validate_goat" at ./bucardo line 6850.

I am able to connect to the database via psql by setting up the .pgpass file : psql -U bucardo


I have also configured the pg_hba.conf file to allow access to all tables for the bucardo user

host    all              bucardo            trust
host    all             all             all                     md5

The last step I was tried was to enable the extension and lang for my database for plperlu with no effect as well.

Does anyone have any ideas on the steps I could be missing to get the authentication working and allow me to add a table?


Sean Logan


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20170614/1b1ae1a1/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.jpg
Type: image/jpeg
Size: 1465 bytes
Desc: image002.jpg
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20170614/1b1ae1a1/attachment-0001.jpg>

More information about the Bucardo-general mailing list