[Bucardo-general] bucardo error with bulk copy

Vineeth Chandran ckvineethchandran at gmail.com
Sun Nov 11 07:38:57 UTC 2018

Dear Team,

I am stuck with an error in Bucardo and require some help to proceed

So i have a Postgres database which i am trying to migrate. In order make
sure the migration only takes a minimum downtime, i was using the bulk copy
mode where in my "onetimecopy" is set to 2 so that once the bulk copy is
completed, it moves to syncing the delta.

My problem is that few of the tables in my DB are big. I tried doing a
migration of database without including the big tables and it worked fine.
However when i include the bigger table, it tries and migrates those bigger
tables (For instance this table alone takes 6 hours for Bucardo to migrate).

I see per logs that it did successfully copy data from that table and then
Bucardo fails with the below error.

* Kid has died, error is: DBD::Pg::st execute failed: SSL SYSCALL error:
EOF detected at Bucardo.pm line 4985. Line: 5453 Main DB state: 08000
Error: 7 DB dest_db state: ? Error: none DB source_db state: ? Error: none*

I am running my bucardo on an AWS Memory optimized R4 24X large and the
whole process of Bucardo is not even using 5% of the system, so i know its
not a memory issue.

Any directions on this will be really appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.endcrypt.com/pipermail/bucardo-general/attachments/20181111/6f26ef58/attachment.html>

More information about the Bucardo-general mailing list